Question: Ping Doesn’t Work in a Simple Network

certskills
By certskills May 26, 2014 09:05

After reviewing this simple #CCNA question, I wondered if it was too difficult. But it’s a blog – we can always discuss the pieces. Today’s post has a multi-choice question about troubleshooting a seemingly simple problem: two hosts on the same switch, designed to be in the same VLAN, cannot ping each other. The interfaces are up/up – what’s wrong? Question is here today, answers in a few days.

The figure shows a simple small network in which all users should be in the same VLAN. A network engineer just connected to SW1’s console and issued a show interfaces command. The command lists a line status and line protocols status of “up” for both ports F0/7 and F0/8. However, when the user of host A issues a ping command listing host B’s IP address, the ping fails. Choose all answers which, if true, would definitely cause A to not be able to ping B?

A. F0/7 is configured to be in VLAN 2, and F0/8 has no configuration related to its VLAN assignment

B. Host A is configured with IP address 10.1.1.1, and host B is configured with IP address 10.2.2.2

C. A show interfaces vlan 1 command lists a line protocol of administratively down

D. Host A uses mask 255.255.255.0, and host B uses mask 255.255.255.128

E. Port security on SW1’s port F0/7 matches traffic from only one MAC address, namely host A’s MAC address

Answer: Switch Forwarding to Default Gateway
Answer: Ping Doesn't Work
certskills
By certskills May 26, 2014 09:05
Write a comment

12 Comments

  1. Luca May 26, 17:16

    hi,
    well, not sure whether I can accept A as answer as I have tried to put an port into an unassigned VLAN and it always go back to the default VLAN 1.
    Not really sure I can accept B, since no subnet mask is given so I am assuming is its default one 255.0.0.0.
    C is not acceptable and only line status can be administratively down …
    D is plausible, however, different subnets entails different default routers, and we know that both hosts were designed to be on the same VLAN(and subnet), the Host OS would have raised an exception at any network misconfig.
    E. should not be an impediment.

    Reply to this comment
  2. Peter Norcross May 27, 00:44

    If the answer is what I think it is, I don’t think it’s too tricky for CCNA. I wouldn’t be surprised if I saw something like this on the ICND2 (just passed back in March), but given my preparation for the CCNP, I would expect it more in the CCNP Switch exam. Again, that’s give that I’m getting the answer right :P.

    Reply to this comment
  3. M May 27, 15:26

    Answer is B and D

    Wrong answers.
    A : because question mentioned The figure shows a simple small network in which all users should be in the same VLAN.

    C : Quentin mentioned The command lists a line status and line protocols status of “up” for both ports F0/7 and F0/8. If theports are up than Vlan 1 should be up. By default al ports are member of Vlan1 by default.

    E : Port security never matches traffic based on mac address .

    Reply to this comment
  4. A May 28, 01:48

    Hi!

    Answer is B and D.

    Reply to this comment
  5. Just Me May 28, 02:13

    I’m thinking about an IP issue or an active firewall in Host B…:)

    Reply to this comment
  6. CCENTSkills May 28, 14:29

    See the ping back link for the answer/explanation…

    Reply to this comment
  7. AreNET October 7, 05:41

    A B C D

    Reply to this comment
  8. Kristian October 27, 17:37

    Only A is definitive.

    B – That would “not be true if the Class A address had a default Class A mask, 255.0.0.0 – as it does not state the mask, we cannot say 100% this would be true, so rule out this one.

    C – if the devices were configured to use Vlan1 then this would be true, but as it does not state what VLAN they are part of (as it could be different) rule this out.

    D – My understanding is if the devices had IP’s within .126 and the PC’s considered the IP to still be within the Default gateway range, this would not be the cause, so again, rule out….(I may be misunderstanding here though)

    E – Port security even if configured, would not affect frames being sent to host A, seen as host A and B have not switched ports and A is still on Fa0/7 – then only of another device replacing host A (if 1 max mac address and that being host A’s mac, was configured in port security) – one example could be Host A PC has been replaced with another Host A PC because of some Windows blue screen or whatever, but there was no mention of Host A PC having been replaced/swapped, so again, rule this out.

    To be honest I answered on a piece of paper then clicked for answer, so thought I would come back and answer why I got only A….

    P.S Thanks for all these blogs, they are very good!

    Reply to this comment
    • certskills Author October 28, 12:39

      Kristian,
      Thanks for the post! I think we agree, per the answers post. Thanks for the detail!
      Wendell

      Reply to this comment
      • Kristian October 29, 19:27

        Hi Wendell, sorry I actually meant to post answers to the Answer section and not this section! As author of the blog can you move/delete my explanation as to not ruin it for anyone else in future……I can’t see anywhere that gives me the option of moving/deleting the post.

        Reply to this comment
        • certskills Author October 31, 14:01

          Kristian,
          Thanks for the note. Happens all the time – no worries. I can’t move it and make it look like it’s from you. If you want to take the time to re-post to the answers post, I’ll notice that and delete it here. Til then I’ll leave it here. But thanks for asking!

          Reply to this comment
View comments

Write a comment

Comment; Identify w/ Social Media or Email

Subscribe

Subscribe to our mailing list and get interesting stuff and updates to your email inbox.

Thank you for subscribing.

Something went wrong.

Search

Categories